Einzelnen Beitrag anzeigen
Alt 26.08.2006, 22:49   #1
Kabak
Lausbub
 
Benutzerbild von Kabak
 
Registriert seit: 11.12.2002
Ort: Unterheinsdorf
Fahrzeug: DK34098 GF66391
Standard Frage an Daten-Bus Spezialisten (K-Bus)

Ich fang am Besten mal beim Urschleim an:
Wie jeder weis, hat der E38 hinten an der Frischluftdüse im Mitteltunnel 2 Stellrädchen (I-0 und Warm-Kalt) Mit Luft wird diese Düse über einen Luftkanal versorgt, der vorne unterm Ascher aus dem "Klimakasten" kommt. Und gesteuert wird die Luftzufuhr und die Lufttemperatur über eine sogenannte Schichtungsklappe, welche die 3 Stellungen Warm/Kalt/Zu hat.
Wenn ich das Stellrädchen I-0 auf 0 drehe, wird eine Masse geschalten, die dann ans Klimabedienteil weitergeleitet wird, das gibt dann der Klappe das Signal auf "Zu" zu stellen.
Wenn ich das Warm/Kalt Rädchen drehe, wird ans Klimabedienteil wiederum ein Singal gegeben, die Klappe auf "Warm" bzw Kalt" zu stellen, vorrausgesetzt, die I-0 Betätigung ist auf "I", logisch.
Wenn ich den Stecker des I-0 Rädchens abziehe, passiert schonmal garnix, da ja keine Masse mehr geschalten werden kann. Die Klappe steht also nict auf "Zu".
Jetzt kann sie ja nurnoch auf "Warm" bzw. auf "Kalt" stehen.
Das Signal was das "Warm-Kalt-Rädchen" von hinten ans Klimabedienteil schickt, ist genau dasselbe Signal, wie das, vom "Warm-Kalt-Rädchen" an der Luftdüse mittig im Amaturenbrett.
Die beiden Leitungen führen zusammen ans Klimabedienteil.
Wenn ich also jetzt hinten auch noch den Stecker des "Warm-Kalt Rädchens" abziehe, kommt permanent Luft hinten raus, undzwar so, wie ich es vorne in der Mitte an dem Rädchen einstelle.
Dreh ich vorn auf Warm drehe, stellt die Klappe für die Fondlüftung auf "Warm" und umgekehrt.

Nun hab ich mir ja das Fondgebläße nachgerüstet.
damit jeder wies was ich mein:Externer Link (&Ooml;ffnet in neuem Fenster, der Forumsbetreiber distanziert sich vom Inhalt extern verlinkter Seiten.) 

Die Luftmenge reguliert ein Gebläßemotor im Luftkanal unterm Mitteltunnel.
Die Temperatur, die ich jetzt hinten an dem Bedienteil einstelle, wird mit einem Wärmefühler in der Fondaustrittsdüse verglichen, und über eine Leitung zum K-Bus Verbinder (hinterm Hanschuhfach) wird ein Datentelegramm ans K-Bus geschickt (welches ja auch mit dem Klimatronicbedienteil verbunden ist!).
Dieses Datentelegramm soll laut WDS* die besagte Schichtungsklappe (Warm/Kalt/Zu) in die jeweilige Position bringen.
Also die Schichtungsklappe wird ausschließlich nurnoch via K-Bus vom Fondgebläße Steuergerät/Fondgebläßebedienteil geregelt.
Weiter steht im WDS*, dass,
wenn ich vorn am Klimabedienteil auf "Defrosten" schalte
oder durch Betätigung Fahrerseite Gebläße auf "-" die Lüftung vorn abschalte,
die Fondklima auch komplett abschalten soll.
Dies bekommt das Fondklimabedienteil ja auch über K-Bus gesagt.

*BMW Wiring Data System

Jetzt hab ich folgendes Problem:
Die Schichtungsklappe macht immernoch nur das, was das vordere Drehrädchen sagt, also sie stellt unabhängig von der hinten eingestellten Temperatur auf "Warm" bzw. "Kalt". Sie stellt so, wie man es am vorderen Rädchen vorgibt.
Desweiteren schaltet die Fondklimatisierung auch nicht ab,
wenn ich auf Defrosten schalte, bzw.
vorn das Gebläße auf der Fahrerseite ausschalte (Klimabedienteil vorn schaltet sich aus)
Hinten geht das Klimabedienteil NICHT aus, der Lüftermotor läuft weiter und macht sich fast alle, weil ja die Schichtungsklappe vorn auf "Zu" schaltet.

Kurz: Das Fondgebläßebedienteil/Fondgebläßesteuerteil kommuniziert nicht mit dem Klimatronicbedienteil vorn.
Wie gesagt, die beiden Teile kommunizieren übers K-Bus.

Was ist hier verkehrt?
Muss der Wagen/Das Klimatronicbedienteil erst via DIS codiert werden, damit er "erkennt" dass er jetzt ein Fondklimasteuergerät hat hat und dessen K-Bus Telegramme vearbeiten kann?

Wäre über jede Hilfe dankbar.

MfG Tom
__________________
Kabak ist offline   Antwort Mit Zitat antworten